Geocat 58 - Disegno e import punti CAD ... e occhio alle rilevazioni difettose

Ciao a tutti,
come ho avuto modo di dirvi in altre occasioni, nel momento in cui vengono apportate al programma modifiche di carattere sostanziale, è abbastanza probabile che tali modifiche comportino qualche effetto collaterale, nel senso che alcune funzionalità del software che fino a prima funzionavano regolarmente, dopo le modifiche presentano delle anomalie. In gergo informatico si chiamano “bug di regressione” ed e purtroppo quello che è successo anche con il recente aggiornamento di Geocat 53 nel quale ho riorganizzato l’intero motore di calcolo per renderlo compatibile con i rilievi contenenti migliaia di punti (vedi IMPORTANTE - Geocat 53 - Rilievi di grande estensione e ottimizzazione calcoli - #12 di Gianni_Rossi).

Il geom. Sergio Roman (Malo - VI) mi ha infatti segnalato:

  1. la comparsa di messaggi di errore come quello di seguito riprodotto durante la creazione del disegno CAD, che tuttavia non impedivano la generazione del DXF:

  1. un errato posizionamento di nuovi punti creati da CAD e importatti a ritroso sul rilievo GPS di Geocat:

Ho quindi risolto entrambe queste anomalie nel nuovo aggiornamento n. 58. Per aggiornarvi vi basta come al solito accedere al menù Software | Geocat di www.topgeometri.it e scaricare il file di installazione (Setup, se non avete ancora installato Geocat 5.02 nel computer, oppure Upgrade se invece lo avete già installato).

Note per Sergio Roman … occhio alle rilevazioni difettose

Nel correggere il problema dell’import nel rilievo GPS di punti creati sul CAD, ho verificato anche l’import nel rilievo TS e sul tuo rilievo ho riscontrato il problema che ti descrivo di seguito, con riferimento all’immagine sotto riprodotta.
Nel disegno ho tracciato la congiungente tra i punti 110 e 111 e poi ho esportato il suo punto medio chiamandolo 1001. Se carico questo punto sulle stazioni 300, 400, 500, il tutto mi torna perfettamente, nel senso che, se dopo averlo importato su Geocat, rigenero il disegno ex novo, il punto 1001 mi va esattamente sul punto medio della congiungente 110-111.

Se invece il punto 1001 lo carico sulla stazione 100, come vedi qui sopra, e ricreo il disegno, questo mi viene spostato di 90 cm sulla destra e presenta, rispetto alla congiungente 100-punto-medio un’errore angolare di 1.4456g come vedi invece qui sotto:

Allora ho indagato sulla causa di questa incongruenza, pensando ad un errore di programma legato sempre alle recenti modifiche, così come è successo per i punti GPS. In realtà, facendo il calcolo locale del rilievo, ho invece appurato dal report di dettaglio del calcolo che il problema è dovuto alle tue rilevazioni angolari di orientamento dalla stazione 100 alle altre stazioni e punti rilevati dal GPS, rilevazioni che risultano difettose in misura a mio avviso eccessiva. Lo puoi appurare tu stesso attivando il comando (icona) Report dettaglio calcolo dalla tabella delle coordinate. Si tratta di un prospetto dettagliato di tutti i passaggi di calcolo svolti dal programma che nessun utente Geocat guarda mai, ma che invece è secondo me un documento importantissimo per verificare la bontà del rilievo e la presenza di rilevazioni diffettose. Come vedi qui sotto, la media della correzione angolare calcolata dalla stazione 100 orientata alle altre stazioni e/o punti TS presenta un sqm di ben 1.8g, il che è ovviamente un valore eccessivo e indice di rilevazioni non precise. Ovviamente questo errore angolare si riflette poi sul punto 1001 importato da CAD, cioè il punto è importato correttamente (quindi angolo e distanza sono quelli sul punto medio) ma poi il successivo calcolo che rigenera il disegno si porta dietro l’errore angolare della stazione 100 che sposta il punto verso destra di ben 90 cm.
Infatti, come ti dicevo, se importi il punto sulle altre stazioni, il problema non si manifesta.

Volevo segnalare come la validità di un programma è dato per il 50% dal Software e per il 50% dall’ assistenza, ma in questo caso l’ assistenza vale molto di più in quanto è sempre efficiente-precisa-competente-veloce. Sono più di 25 anni che uso i programmi di Gianni ( mi sà che sono uno dei più vecchi del gruppo) e ancora mi meraviglio della competenza di Gianni al quale voglio rivolgere i miei più sentiti ringraziamenti. Un saluto a Tutti. Sergio

Ciao Gianni.
C’è un problema con salvataggio lavoro.
ho aperto un lavoro esistente, l ho salvato con nuovo nome, ho modificato alcune battute e cancellato altre, l ho salvato e quando vado per riaprirlo non lo trovo mentre trovo cambiato quello con il nome originario.
Grazie Sergio

Gianni mi accodo, dopo aver aggiornato alla versione 5.02.0061 non riesco più a importare i nuovi punti creati da CAD. Il programma mi rilascia il sottostate messaggio di errore


Nel CAD i punti si creano correttamente ma quando passo su GeoCat nella scheda libretto di campagna e seleziono “importa punto CAD” nulla ottengo l’errore sopra esposto.

Ciao Andrea,
da quel messaggio di errore mi sembra di capire che il problema sia il seguente: tu hai Geocat versione 5.02 mentre l’applicativo CAD è ancora della versione 5.00 (questo probabilmente succede agli utenti AutoCAD). Se è così, dovresti trovare il file LOADPUNT.POL (che contiene i punti generati dal CAD) nella cartella dei dati del programma, cioè qui (“Gianni è il nome dell’utente del computer)”:

C:\Users\Gianni\AppData\Roaming\Tecnobit\Geocat\502

Come vedi la sotto-cartella finale è la 502, mentre invece nel tuo caso il file si è registrato nella sotto-cartella 500. Se così, copia il file LOADPUNT.POL sulla 502. A quel punto Geocat lo trova e ti importa i punti.
Fammi sapere.

Ciao Gianni.
Ho lo stesso problema. Ho costituito dei nuovi punti con gestarcad dalla stazione 100 che è la stessa sia per gps che per stazione totale. Se provo a caricare i punti in geocat li carica solo nel gps e non nella stazione totale.

Scusa ma ho un altro quesito.
Mi sono accorto che per fare libretto pregeo devono essere aperte tutte le le finestre del rilievo stazione totale, gps e contorni, altrimenti carica solo quella aperta. Non so se il programma è impostato così o se è da sistemare. grazie. Sergio

Ciao Sergio.

No, non è lo stesso problema di Andrea, anche se il messaggio è uguale. A te esce perché il programma non prevede che gli stessi punti generati dal CAD siano importati contemporaneamente sia come punti TS che GPS.
Nel tuo caso, essendo che la stazione 100 è sia TS che GPS, succede che, una volta importati sulla tabella GPS, poi Geocat elimina quei punti dall’import considerandoli già importati, quindi non li importa più sulla tabella TS.
Tieni presente che il programma non dà priorità alla tabella GPS rispetto a quella TS come può esserti sembrato, ma semplicemente carica i punti sulla tabella dalla quale tu hai cliccato l’icona Importa punti CAD (vedi immagine qui sotto). Se l’hai cliccata finché eri sulla tabella GPS, li importa sulla tabella GPS come baseline; se invece l’hai cliccata finché eri sulla tabella TS, li importa sulla tabella TS calcolando le letture celerimetriche.

Quindi, se vuoi importare i punti CAD su entrambe le tabelle, leggi quanto ho scritto ad Andrea nel post sopra circa la cartella dati di Geocat e il file LOADPUNT.POL, poi fai così:

  • prima di importare i punti, fai una copia del file LOADPUNT.POL (ed esempio sul desktop);

  • attiva l’icona Importa punti CAD dalla tabella GPS e importa le baseline;

  • copia il file LOADPUNT.POL che ti eri salvato nella cartella:
    C:\Users\Gianni\AppData\Roaming\Tecnobit\Geocat\502
    (serve perché il file precedente viene cancellato dopo il primo import);

  • attiva l’icona Importa punti CAD dalla tabella TS e importa i dati celerimetrici.

Come saprai tutta questa gestione sta per essere soppiantata dal nuovo CAD integrato di Geocat che farò uscire a breve, per cui su questo nuovo strumento potrò anche prevedere l’import contemporaneo di punti CAD sia come GPS che TS (anche se sinceramente non ne vedo l’utilità).

No, non è impostato così, è un altro effetto collaterale della recente ristrutturazione del programma. L’ho testato con il tuo rilievo, in realtà erano solo le righe 7 dei contorni a non essere create nel libretto Pregeo se la tabella contorni era chiusa. Le righe 1 e 2 del GPS uscivano regolarmente.
Ho sistemato nell’aggiornamento 62, incluso anche il fatto che la finestra del libretto Pregeo non si chiudeva cliccando sulla X in alto a destra ma solo chiudendo il rilievo.

Fammi sapere se ti funziona.

Allora Gianni, ieri ho fatto come mi avevi detto copiando il file LOADPUNT.POL nella cartella 502 ma non dalla cartella 500, in quanto anche lei non la conteneva, ma dalla cartella 415 che lo conteneva. Dopo di che ha funzionato l’importo dei nuovi punti generati da CAD. Questa mattina ho iniziato a generare dei contorni sempre da CAD e appena tento d’importarli stesso errore. Allora vado a vedere di nuovo la cartella 502 e non trovo più il file LOADPUNT.POL copiato ieri (???). Lo reinserisco nella cartella 502 copiandolo ancora dalla 415, rifaccio l’importazione del contorno generato da CAD e mi reimporta di nuovo i punti generati ieri. Ora non capisco perché il file copiato ieri è sparito di nuovo e come mai non importa i contorni generati oggi.

Ok verificato tutto funziona bene. Grazie

Gianni ho capito una cosa il file LOADPUNT.POL mi si crea solo nella cartella 415 per i punti creati da CAD

Ciao Andrea,
allora ho capito, tu hai aggiornato Geocat alla versione 5.02 ma non hai mai ricaricato l’applicativo CAD (menu Topografia) aggiornato sul tuo AutoCAD, quindi stai ancora usando il vecchio applicativo 4.15 che ti salva i file nella cartella 415.
Ti basta quindi scaricare da AutoCAD il vecchio applicativo e caricare quello della versione 5.02, le istruzioni su come fare le trovi su questo topic:

Come caricare il menù Topografia di Geocat su AutoCAD e GstarCAD

Fammi sapere se risolvi.